Google Drive operation Download returning unknown error

Describe the problem/error/question

Google Drive node with Download operation returning
“ERROR: UNKNOWN ERROR - check the detailed error for more information”

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
    at Object.googleApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Google/Drive/v2/transport/index.ts:64:20)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Google/Drive/v2/actions/file/download.operation.ts:200:15)
    at Object.router (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Google/Drive/v2/actions/router.ts:30:26)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Google/Drive/v2/GoogleDriveV2.node.ts:25:10)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/src/Workflow.ts:1374:8)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:1048:29
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:1724:11

This is my node, I have added OAuth2 credentials.
image

My n8n is latest version 1.31.2

I tried to make this example workflow → Ask questions about a PDF using AI | n8n workflow template

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

What’s the size of the file?

It’s super small pdf, 180 KB.

I have just tried with a variety of different sizes and from all of the different ID input options and it worked every time.

Can you try the “By ID” File input instead of link and see if that works?

Have you used google drive before? is it possible you didn’t set up credentials correctly or didn’t set up the right scopes?