Google Sheet is not loading the work book

Describe the issue/error/question

I am trying to read and write a new row of data but it’s not getting added.

What is the error message (if any)?

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.217.2
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: Docker
1 Like

Hey @Sankar_Prakash

Can you double check the credentials?

Thanks for responding @mcnaveen

Then I proceed with advanced options and confirmed. Through below screen I make sure that credentials connected successfully.

1 Like

That’s really strange. Do you see any error in Browser console?

No error except above one. Am I did anything wrong?

Hi @Sankar_Prakash,
be sure that you have the Google Sheets API enabled in your Google Cloud app.

In Google Cloud:

  1. Select your project
  2. Go to “APIs and services”
  3. Go to “Enabled APIs and services”
  4. Check if you have “Google SheetsAPI” in the table at the bottom of the page
  5. (if not) Click on “ENABLE APIS AND SERVICES” and then search and enable the Google Sheets API

Let me know if that helps!

Thanks for your response @giulioandreini , after mutiple attempt its working through by URL

1 Like

Glad to hear it works @Sankar_Prakash, let me know if you need more assistance


Sure @giulioandreini Thanks.

@mcnaveen I just created new sheet via n8n then read all the rows from the existing excel by providing URL. Anyway Thanks for your response.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.