Google Sheets : Can't Run ANY Operation (READ, INSERT, UPSERT, UPDATE) N8N v207.1

While using GoogleSheets with “Service Account” credentials I get the error:

ERROR: UNKNOWN ERROR - check the detailed error for more information

error:25066067:DSO support routines:dlfcn_load:could not load the shared library



  • n8n version: 207.1
    -Running N8N via Cloudron

Hey @KevinK,

Have you also raised this on GitHub as well?

Yes I have …

1 Like

Hey @Jon, so the soul of most of my Workflows revolve around in-out of Google Sheets data. Any chance you can check if this error I’m getting is a Version issue so I can maybe downgrade (If so, how do I go about?)


Hey @KevinK,

It is on my list to check out but there were a few requests from last night that I need to reply to as well so it might be another 30 minutes or so until I get back to that one.

Downgrading should be possible normally you would set the version you want to use in your docker command or with the npm command but I don’t know how the Cloudron install is done. Do you have any documentation that you followed to install it?

Appreciate it.

Here’s their Panel Install Documentation : Cloudron - Install Cloudron
& here’s their information with regards to their hosting of n8n : n8n - Cloudron Docs

Installation from their panel once installed is simply a “Click to install” : )

Hey @KevinK,

Looking at their docs it looks like they are using the npm version so it would be a case of running npm install [email protected] where xxxx is the version you want but I don’t know if it is global and how they are running it as a service maybe through pm2.

It might be worth asking the Cloudron support team how to downgrade as sometimes the one click applications can do odd things when installing.

Quick update…

I have closed the github issue so we can keep everything here and not have it split between 2 different places.

When it comes to updating the sheet you should be able to do that using oauth if you have access to the sheet so that could be a workaround. I am going to give a service account a test now to see what happens.

Let me just work on setting up n8n on a fresh stand-alone server to avoid this in the future again… In the meantime I’ll reach out to their Support Team as well as suggested.

I’ll go ahead & try the Oath Authentication.

Thank you!

Turns out I already had a service account in my install, I have given it a test and it does appear to work.

It could be an issue with the version of Node installed on Cloudron, Is there a way to check that?

Then it could be an issue with their N8N install, because I’ve done a fresh install of Cloudron + N8N twice with the same results (from different VPS Providers)

I’ve emailed them awaiting to hear from them if it’s a Node issue.

1 Like

Have you tried setting up n8n without Cloudron? I guess if you can SSH into the box you could try running n8n --version to see if that has any output.

Hey @Jon , did a setup with Docker & everything seems to be running okay - as far as Google Sheets is concerned. It seems the error is related to their N8n on Cloudron.

Thanks for the assist!

1 Like

Hi there.

I had the same problem in a local instance.

n8n version: 0.150.0
node version: v14.17.1

Solved this with an answer on node repository

As a workaround, I ran export OPENSSL_CONF=/dev/null before starting node. This prevents the issue and the code begins to work, however this also bypasses the config for openssl.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.