Google sheets refreshing fields not working

Describe the problem/error/question

When building out a process that includes updating a Google sheet. I manually map variables to the right columns. But when I add a column to that sheet, I have to start all over again filling in the right variables in the right fields.

To make it more clear, I recorded a loom: Loom | Free Screen & Video Recording Software | Loom

Working likes this is really frustrating and time consuming. What am I doing wrong and how can I fix this?

Please share your workflow

Not relevant

Share the output returned by the last node

Not relevant

Information on your n8n setup

  • n8n version: n8n@ai-beta
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud and selfhosted same problem
  • Operating system: Windows

That’s a good find because that probably should work a little better. Maybe make a feature request to make a reload button or something.

I did find a workaround.
Set Mapping Column Mode to Automatic then back to Manual and it refetches everything (including new ones) and keeps all of your data there

2 Likes

Hi Liam, thanks that work around goes a long way to solving my problem! :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.