Got gray answer and loading animation


After I run node, I got an answer, but text is gray and loading animation keep loading until I refresh the page.


What am I doing wrong?


I tested it also with different API and see that it’s return nothing when it should return sth. So I am not sure if it’s not just getting data for so long time, Is it possible that loading data can take like 5 minutes or more?

Hey @Shirobachi,

How are you running n8n? There seems to be a problem with your instance. Did you try running any other nodes except the YouTube node (you can try the HackerNews node, you don’t need to create credentials for the node)?

So I tried YT and notion, I checked now your suggestion and after few seconds I got answer, but loading animation was still there

I checked google console, and it says that I used API, so n8n connected with Google.

I run it on docker, self-hosted with nginx, I run it with following command

sudo docker run -d --restart always --name n8n -p -e N8N_BASIC_AUTH_ACTIVE=true -e N8N_BASIC_AUTH_USER=simon -e N8N_BASIC_AUTH_PASSWORD="******" -e N8N_HOST="" -e N8N_PORT=443 -e N8N_PROTOCOL="https" -e WEBHOOK_TUNNEL_URL="" -e VUE_APP_URL_BASE_API="" -v ~/n8n:/var/www/ n8nio/n8n

And this config in nginx

server {
  listen ssl http2;

  ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;

  server_tokens off;

  gzip on;
  gzip_buffers 4 32k;
  gzip_types text/plain text/css application/x-javascript;
  gzip_vary on;

  location / {
    add_header Access-Control-Allow-Origin *;

    ssl_certificate /etc/letsencrypt/live/; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/; # managed by Certbot

Thanks for help ^^

Sounds like an issue with Server-Sent Events. Please check the following nginx configuration and add missing ones to make them work correctly:

Yes, I added missed locations and listen, and it’s working by now.

Lovely, thanks!

1 Like

Great to hear! Have fun!

1 Like