Having trouble connecting n8n EKS deployment to RDS instance

  • I have no issue with n8n on EKS when using a pod for postgres - but cannot get it to work when trying to point it to an RDS instance (in same VPC/subnet and security group rules allow connections over 5432)

What is the error message (if any)?

Error: There was an error initializing DB

DatabaseError: no pg_hba.conf entry for host “”, user “n8nDBadmin”, database “n8n”, no encryption
(The IP it references is one of the secondary IP’s for the EKS worker nodes and not the RDS private IP)

Information on your n8n setup

  • n8n version: - 1.15.2
  • Database (default: SQLite): - Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queued mode with redius
  • Running n8n via (Docker, npm, n8n cloud, desktop app): - AWS EKS

it’s possible that the RDS instance only allows SSL.
Please try setting the env variable DB_POSTGRESDB_SSL_ENABLED to true.


Thanks for that! I think that may be it - I think I’ll need to get all the right certs and keys uploaded but this looks promising

closing the loop here - that ended up being it! I had to enable the option you mentioned and also import the AWS RDS global cert into the container and set the DB_POSTGRESDB_SSL_CA_FILE variable to point to it but once that was done I’m up and running with the deployment files pointing to the RDS host. Thanks again for your help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.