Help needed with Docker Compose + Traefik2 Install

Thanks for the suggestion. I saw you made a similar one in other threads. I do in fact have node-red, and was using it to test n8n’s http request :slight_smile:

In all honesty, I am trying both solutions out to see which one is “better”. I am not holding this initial hurdle against n8n very heavily. Node-red feels a bit less of a service to service bridge (like Zapier). I feel it is perfect for my Home Automation via Home Assistant. Perfect for flipping switches, etc. I still need to get a feel for it as an incoming Webhook to translate incoming data and through some rules transform it to a Google Sheet (for example).

At the end of the day, if the logic I need ends up being clunky and hard to easily achieve through the UI of these tools, I will just write the code myself in Python and throw it up in a simple Docker container using something like Flask, or if I get adventurous Django :smiley:

1 Like

I understand where you’re coming from. I prefer to write raw Python myself. I had a tough time transitioning my AppDaemon scripts (Python) to Node-Red for Home Assistant, but once I got my head wrapped around the simple concept of messages in Node-Red, I realized how much simpler it was instead writing callbacks and classes for AppDaemon.

Node-Red just sends JSON or raw text via the msg object from node to node. Whatever data is received in the first node as a trigger can easily be read 30+ nodes later. The ability to add debugs anywhere in the path of a flow is also a huge difference maker. I would go on about the advantages of Node-Red over N8N, but another dick may get butthurt about it.

I kind of went the other way and moved my old Python scripts over to n8n although I did still have some more complex things running in Go that I didn’t move over :slight_smile:

I find it is all about using the right tool for the job and sometimes that won’t be n8n which is fine, The one thing I would ask though if you have a moment is if you have to use something else drop in a feature request so we can improve.

The logging that has been mentioned is something that bugs me as well and I think there are things we can do to improve on what we have it is just a case of working out the best way, Things like this issue though where it isn’t working from one machine but other machines are fine is a bit tricker and would need more troubleshooting on the client side but if we can get a way to reproduce it we can see if there is anything server side we can do.

That is indeed a feature that is a game changer. I sort of wrote a function node to just log to the console the input it got. So I can see it in Dev Tools.

1 Like

I still need to define what use cases I want in n8n vs node-red.

One huge feature in my mind is security related. I feel super uneasy putting API keys, username/passwords to connect to services which are not natively supported by the credential system. A more generic secure Key/Value store would be very useful.

Regarding this specific issue, as it has morphed, what else I can do on the client side to help provide clues as to the true root cause of the problem?

@anon3028993 it would probably be better to just ignore your post, but since you’re intentionally abusing my given name, I’m forced to educate you on the topic of dicks … and whilst we’re at it also try to explain the problem with dick pics … When I was young, an English-speaking person asked me whether Dick was my nickname. Not mastering the English language yet, I answered the question by saying that I was a real Dick. It then struck me that there were more dicks than just the one with the capital D … so essentially big and small dicks. Apparently, somebody had bound the word Dick to penis, and out came dick with a small d. This small dick has become quite popular, although being used in a lot of negative ways. In more recent time, small dick has been bound to the short word for picture, and voilà; the dick pic was born. Apparently, there are men out there who take pictures of their private parts and send this to other people. Of course, this is totally unacceptable! And to real Dicks (capital D/persons with first name Dick), this has introduced another layer of complexity. I guess I do not have to explain what a selfie is, and what happens when I take a picture of myself. You guessed right; a picture with Dick in it, or Dick pic. Unfortunately, in spoken language, there’s no way to differentiate between lower- and uppercase. And even worse, not just selfies, but all pictures with me in it are essentially pics with Dick. In order to avoid confusion, I’m now trying to stay out of pictures as much as I can. I’m now even using a selfie of my diseased dog as my avatar. Now you may ask yourself why don’t you, or any of the other big Dicks out there, change your name? As far as I’m concerned, this is quite simple; it’s my given first name! So not Richard, not Rick, but plain old Dick :sunglasses:


Thank you for adding to the humour angle. I am genuinely sorry your given name is such a source for confusion…

1 Like

Thanks a lot @dickhoning!

I did silence @anon3028993 (so he can not post anymore), have no problem at all with people mentioning n8n alternatives like node-red That is totally fine… After all, is it a great project and there are very often good reasons to use it rather than n8n. Simply choose the right tool for the task, and there is not one to rule them all. But it is about how it is done. Doing it in a non-constructive manner with personal first-grader jokes, is not the right way and nothing I tolerate here. Please report such behaviour in the future that we can silence people faster. Thanks!


Ah, he got actually already deleted by the team. So me silencing him was not really necessary :wink:

1 Like


Have you finally managed to track down this issue and how to solve it ?

I’m having the same problem on a server hosted instance of N8N 0.174.0 using ECS. The issue seems to be the same - impossible to run and test any workflow because the button keeps spinning forever and when the STOP button is hit there’s a 404 (i assume because the workflow is not running anymore).
It seems that the front-end don’t receive any response callback from the run even if some magic is done server side.
The issue is browser independent, and I don’t run any kind of firewall or proxies on my laptop.

I see the same message on my cloudwatch log files :
Attempt to read execution was blocked due to insufficient permissions

Well n8n is working for me, so yes the original problem I was having has been resolved. Here are some of the points which helped me get it to a working state:

  • Using the local HTTP URL when accessing it’s own REST API. In my case using Traefik the external facing URL might be while the container itself is HTTP on the internal network, so accessing its own REST API from the container itself would use an URL like http://n8n:5678/rest/

  • In the docker compose service definition you still need to use the external facing information so something like:

      N8N_HOST: "n8n.$DOMAINNAME"
      N8N_PROTOCOL: "https"
      WEBHOOK_URL: "https://n8n.$DOMAINNAME/"

I think for me the issue was rooted in me trying to access the REST API from the container itself by using the external URL, and when that didn’t work, I tried changing the ENV to the local values, which made the whole thing not work.

I think to avoid this in the future we should consider improving the Docker documentation about accessing n8n’s own REST API from within the local docker network and what the correct HOST /PROTOCOL is to use in that case.

1 Like

Hello all. The problem repeats one in one except that I do not use Traefik2. I have an nginx reverse proxy server.

“Attempt to read execution was blocked due to insufficient permissions”



Problem solved. Trouble in nginx config.

    location / {
	proxy_buffering off;
	proxy_cache off; 
	proxy_http_version 1.1; 
	chunked_transfer_encoding off;
	proxy_set_header Connection '';
	proxy_pass http://localhost:5678;   

Valid config