Help! workflows gone

Hello, I am desperate

I tried to upgrade my n8n version

ubuntu vps

docker pull n8nio/n8n

Stop current setup

sudo docker-compose stop

Delete it (will only delete the docker-containers, data is stored separately)

sudo docker-compose rm

Then start it again

sudo docker-compose up -d

now all my workflows is gone,
when i try to install again i get the warning…

“WARNING: The DATA_FOLDER variable is not set. Defaulting to a blank string.”

but before everything was ok

see below:


To what was that variable set before? Because before it was apparently set to something else it would not behave different now. Or do you have a .env file?

oh my, I swear I didn’t touch anything I didn’t say above…

but my viariable was ATA_FOLDER=/root/n8n/ lol
I did nothing in the .env file
I didn’t even open since a lot
I fixed it and works
Thank you

Great that you got it working. If you have it in the .env file it should normally read it automatically. So if you do not have one yet or if it is not set there that should avoid that to be happen again in the future.