Heroku Application Error for One Click Deploy Method

Hey folks. I want to know the issue or the extra requirements afer deploying the n8n using one click deploy button to heroku. I simply named the app, and filled the required fields, created a manual encryption key. and other details that necessary. after building the app it was showing application error which is normal, because the SSL wasn’t configured. but then I connected the domain and generated through ACM and now the green status of SSL is visible. but still the Application error persists. H 10 is coming, main error I’m getting is no pg_hba.conf .

So I tried manually updating the database details seeing the postgrsql data credentials. but it’s still in that crashed state.
I tried sharing my logs with chat gpt models and discussed, but they are unable to help exactly.

The logs shows this:
N8N will start on ‘8905’
2024-05-15T02:26:03.572517+00:00 app[web.1]: postgres://u4goikifvqa2brbd4760ac1f9a2ff88838dfb4b4b41b15dcfdc4f14b1e6fa4aed2aa29@ce9oip7r5bp6e2.cluster-czz5s0kz4scl.eu-west-1.rds.amazonaws.com:5432/dchm7je3i4j06t
2024-05-15T02:26:05.761596+00:00 app[web.1]: Initializing n8n process
2024-05-15T02:26:05.999558+00:00 app[web.1]: Error: There was an error initializing DB
2024-05-15T02:26:05.999686+00:00 app[web.1]: DatabaseError: no pg_hba.conf entry for host “HOST”, user “USER”, database “DATAbase”, no encryption
2024-05-15T02:26:08.074217+00:00 heroku[web.1]: Process exited with status 1
2024-05-15T02:26:08.096569+00:00 heroku[web.1]: State changed from starting to crashed
2024-05-15T02:26:08.099827+00:00 heroku[web.1]: State changed from crashed to starting
2024-05-15T02:26:22.350158+00:00 heroku[web.1]: Starting process with command /entrypoint.sh
2024-05-15T02:26:22.942617+00:00 app[web.1]: N8N will start on ‘4208’

and gthe process continues with new ports again and again. may be this is the reson my dyno also in a crashed state automatically. I tried with the comand line
using this command.:
heroku ps -a myapp

What s the solution and problem, does this method writes code in the wrong manner?
Please fix this, I fanyone can experiment with this, and let me know, who has the experties in understanding the codes and actual configuration.

Hoping to solve this problem soon.

Hey @Ripan_Chowdhury,

Welcome to the community :raised_hands:

Are you using our one click option? It could be that DB_POSTGRESDB_SSL_REJECT_UNAUTHORIZED needs to be set to false and DB_POSTGRESDB_SSL_ENABLED needs to be added and se to true

Thanks, I can access n8n now.

I can access the n8n, but this is the issue. When I tried to use the webhook node, sending a post request fro postman, keeping the method in node as post, the postman gave me a 404 response mentioning something like error-pages/no-such-app.html . I can’t put the full error, it’s not taking it with 403.

But the http method to send data to a webhook is working, I have tested with pabbly. But the webhook https is not recieving any data despite showing in pabbly that successfully data forwarded.