Hi n8n, I'm trying to run NPM RUN BUILD command on my forked repo of n8n

Getting below error .
My Node version : v14.0.0 NPM Version: 7.24.0

I ran these comands

  1. lerna bootstrap --hoist
  2. npm run build
  3. npm run dev

npm run build thowing below error.

**

Error

**

INTERNAL ERROR(undefined,undefined) Maximum call stack size exceeded
stack trace:
RangeError: Maximum call stack size exceeded
at /Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/IncrementalChecker.js:171:25
at WorkSet.forEach (/Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/WorkSet.js:18:13)
at IncrementalChecker.getDiagnostics (/Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/IncrementalChecker.js:161:17)
at /Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/service.js:88:41
at Generator.next ()
at /Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/service.js:7:71
at new Promise ()
at __awaiter (/Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/service.js:3:12)
at run (/Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/service.js:83:12)
at Object.run (/Volumes/Extreme SSD/n8nB/n8n/node_modules/@vue/cli-plugin-typescript/node_modules/fork-ts-checker-webpack-plugin/lib/service.js:112:7)

Please let me know if, anything missing out.

Welcome to the community @vinodh-byte !

There are currently some issues with npm v7 that originate on the vue.js side. So best to either use npm v6 or run the following first:

npm config set legacy-peer-deps true
1 Like

HI Jan, Thanks for reply, i was using npm version 6.14.0 initially(i had same problem), but now upgraded to npm 7 and also confingured npm config set legacy-peer-deps true. No luck

Is it the same error?

Hi Jon, Yes, same error. INTERNAL ERROR(undefined,undefined) Maximum call stack size exceeded.

I am not sure if this will help, but worth trying some approaches listed here: javascript - Maximum call stack size exceeded on npm install - Stack Overflow

Seeing the same thing building in a fresh docker instance.

FROM node:14.15

WORKDIR /workspaces/n8n

RUN \
	apt-get update && \
	apt-get -y install graphicsmagick gosu git build-essential python && \
	npm install -g lerna

Tail of log here - hastebin

EDIT: tried and failed

  • npm cache clean --force && lerna clean --yes && npm i && lerna bootstrap --hoist
  • Node v16 with npm config set legacy-peer-deps true and the above
  • Going back to tag [email protected] and trying all the above

What npm version are you using? It has been working fine with npm 6.x for us.

I will ask you to switch to version 6 if you’re using 7 until we fix this issue. We are aware that people had issues building n8n with npm 7.x.

Same dockerfile, fresh container, latest commit and lerna bootstrap --hoist now works.