HighLevel oAuth2: ERROR: Unable to sign without access token: Unprocessabel Entity

Continuing the discussion from HighLevel oAuth2: ERROR: Unable to sign without access token:

Hi huuich, since GHL is deprecating their v1 API in March I figured I had to start down this ridiculous process of OAuth2. I too am getting the Unprocessable Entity error. In your quote you said you had to “add more some parameter in Header”. What does that mean, what did you add in the header? Please elaborate because this whole thing is causing me to bang my head-er against the wall-er.

Describe the problem/error/question

What is the error message (if any)?

Error: Unprocessable Entity

More details

{“statusCode”:422,“message”:[“client_id should not be empty”,“client_id must be a string”,“client_secret should not be empty”,“client_secret must be a string”],“error”:“Unprocessable Entity”,“traceId”:“d8f30389-02e9-4b66-8ebb-b81bc0bc4383”}

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey, did you ever manage to figure this out?

Hey,

It looks like for High Level you would need to create a Generic OAuth2 credential and fill out the fields using the information from High Level.

For the Type it will be Authorization Code and you should be good to go. I will get a ticket sorted out to update the node to work with the v2 node before the cut off.

Hope to see update node High Level to v2 soon.

I can connect like this below pictures but can not working with this node, I have to use http request

Hey @huuich,

Yeah at the moment the nodes will only work with their specific crednential so you would need to use the HTTP Request node.

1 Like