HighLevel oAuth2: ERROR: Unable to sign without access token

Describe the problem/error/question

I am trying to connect to HighLevel API through OAuth2 like this guide Authorization | Integrations API. The authentication process went through as I got the login page and get the “connected” banner like this picture

What is the error message (if any)?

Yet when I try to call the simple API like Get Contacts Get Contacts | Integrations API, I get an error stating that “Unable to sign without access token”.

Please show me how to fix!

Please share your workflow

Information on your n8n setup

  • n8n version: 1.16.0
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker

Hey @huuich,

Looking at the docs it could be that the the Access Token URL is incorrect, Can you try setting it to https://services.leadconnectorhq.com/oauth/token to see if it helps.

1 Like

@Jon Thanks for reply, I’m missing about docs Access Token URL. I’ve tried connect like you guide with new parameter in Setting and successfully, too. But when call API, I get a another error
“ERROR: Unprocessable Entity”

Time
12/1/2023, 12:01:24 AM
Item Index: 0
HTTP Code
rejected
Cause
Data below may contain sensitive information. Proceed with caution when sharing.
{
"status": 
"rejected",
"reason": 
{
"body": 
{
"statusCode": 
422,
"message": 
[...], // 4 items
"error": 
"Unprocessable Entity",
"traceId": 
"aa78ee90-7633-43d8-9871-8b211a878dcb"
},
"code": 
"EAUTH"
}
}
Stack
NodeApiError: Unprocessable Entity
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1548:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:670:19)
    at /usr/local/lib/node_modules/n8n/node

===
P/s: Hi @Jon I’m follow above error and I find out I need to add more some parameter in Header and it’s working. Your guide is solution, thanks you very much!

1 Like

This topic was automatically closed 7 hours after the last reply. New replies are no longer allowed.