How can I remove the n8n_block_env_access_in_node in cloud?


I’m using n8n cloud version and I’ve been trying to get this workflow to work: Send a ChatGPT email reply and save responses to Google Sheets | n8n workflow template

At the HTML5 Email Template I get the “env vars not defined” error, and it says I need to remove the n8n_block_env_access_in_node . I’ve gone through all the other forum posts on this topic, and those typically say to set that node to false. What is the right way to go about doing this in cloud, and how exactly can I either remove/ set it to false in cloud?

Hi @Mr.caribou :wave: Welcome to the community :tada:

You wouldn’t be able to change that setting on n8n cloud, only if you were self-hosting and able to change the environment variables for your own instance.

That being said, I think there’s a solution for you without it - If your cloud username is mrcaribou (as an example), the value would be WEBHOOK_URL=

Could you try using " " instead of $env.WEBHOOK_URL in your code and see if that fixes this up for you?


That worked! Thanks so much @EmeraldHerald. I just joined yesterday and learning the ropes. Really enjoying it so far!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.