How do I handle rate limit errors with OpenAI APIs when using N8n and Google Sheets Flow?

Question for the N8n Community:

As I mentioned in the title, I am currently using a Google Sheets Flow in conjunction with N8n to engage with the OpenAI API, with a click trigger that launches around 200-2k requests. However, I am encountering rate limit errors, and I am looking for a way to request less per second, besides using the retry on error delay within the node.

I already requested a rate increase with OpenAI, but in the end it will probably not fix the underlying architectural issue. If so, what strategies have you used to effectively handle these errors and ensure that your workflows run smoothly?

Hey @David_Seyffer,

If the retry on error delay in the node doesn’t work for you the other option would be to use a Split in Batches node you can then select how much data to send and add a wait at the end before doing the next iteration.

Works! Appreciate it!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.