How do you stop an execution that is waiting + bug in waiting node?

I have a node that needs to wait between 5 and 10 minutes randomly. I achieve this using the expression: {{ Math.floor(Math.random() * (10 - 5 + 1)) + 5 }} and the Wait Unit is set to “Minutes”

It has run “20 Feb at 16:48:24” but is “Waiting until 20 Feb at 21:57:26”

Two questions:

  • How do I kill the execution so the waiting stops
  • Is this a bug or is there a bug in my expression?

Information on your n8n setup

  • n8n version: 1.27.3
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: Ubuntu

Ok, I found the Stop button via the list of “All Executions”. I was looking in the Executions editor, not sure if there’s also a stop button there.

1 Like

Hey @drj,

To fix the other issue if you upgrade to 1.29.1 it should be resolved.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.