How to configure a cron node?

What settings in the Cron node are necessary for the process to start every 5 seconds?

That would be:
Mode: Custom
Cron Expression: */5 * * * * *

1 Like

Thank you, Jan! Everything works great.

You are welcome. Glad to hear. Have fun.

Does this imply that setting it like * */59 * * * * would give me an every hour interval?

If you want an hourly interval then the option “Every Hour” should be used.

Your example * */59 * * * * says run every second on every 59th minute. As there is only one 59th minute in every hour that means:
It would not run at all in the minutes 0-58 and then 60x in minute 59. If you want that it runs exactly once on the 59th minute and you do not want to use the option “Every Hour” then you would have to set: 0 59 * * * *


Just to be SUREEEEE, setting it to 0 30 * * * * would give me a 30 minute interval right?? :smiley:

No, that would mean it runs every hour at minute 30. So at 0:30, 1:30, 2:30, …
If you want to run it all 30 minutes you would have to set: 0 */30 * * *

Anyway for something that simple you can also use the Interval Trigger-Node.

There is however a difference. If you set the Cron Node to: 0 */30 * * * it would run at: 0:00, 0:30, 1:00, … no matter the time you activated the workflow. So if you activate it at 0:28 it would execute the first time after 2 minutes.
If you set the Interval Node to 30 minutes it would run all 30 minutes starting from the time you did activate the workflow. Lets say you activated it at 17:39 the executions would be at: 18:09, 18:39, 19:09, …


well then i’ll just use the Interval node! :smiley: Thanks!!

1 Like