How to transfer information from Excel file by link to G Sheet with correct encoding and filtering


This is the file from which we need to get the information - .
It’ s a price list for car parts

From it we need to take only those rows where the price is greater than 0 (and not blank).
The price column (in Russian - “Цена”) is the O column.

The rows obtained after filtering must be placed either in a local file on the server, or in Google Sheet.
Since there will be several thousand rows (up to 5,000) - the main thing for me to make it work without fail.

How do I make this thing work?

Thank you very much!

Describe the issue/error/question

My problem is that if I solve the encoding problem, then I get data that I can’t present in the correct form.

About error: If set to active, all JSON data is replaced with the data retrieved from binary key. If it is not set to active, the data will be written to a single key. This field is displayed when ‘Binary to JSON’ is selected from the Mode dropdown list.

I can’t present json data in a proper form to put it in a table

Please share the workflow

Information on your n8n setup

  • n8n version: 0.188.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hi @Mikhail,
I used two Move Binary Data nodes to change encoding and the Spreadsheet File node to achieve this.

Here is my example workflow.


Hey @marcus ! Thank you so much for your help! It is work!

Can you please tell me how to save this file? There must be something like this:

If you want to save as csv again you can use another Spreadsheet File node with Operation = Write to File like this:

1 Like

There is the Problem running workflow Request failed with status code 413 on the last node “Write Binary File”

I guess it’s a problem with a large number of rows.

Or maybe something else…

Have you encountered this problem?

I did not experienced a 413 error. Is this error happening in the first Http Request node? Those kind of status code errors usually only occur when making http requests and none of our other nodes do that.

1 Like

Weird. I reloaded the browser tab and everything worked. I tried executing separately by node - the error again.
I’ll keep watching… If this error keeps coming up, maybe someone will help me with it.

All in all, it works! Great job!

Thanks so much for your help and your answers!

1 Like