Http request : is there hidden HEADERS parameters?

Hi all,
i try to read a product with a PIM API Get products (akeneo).
I got good response from appsmith and postman but not from N8N.
It always give an error response :

ERROR: UNKNOWN ERROR - check the detailed error for more information
"application/json,text/*;q=0.99" in "Accept" header is not valid. Only "application/json" is allowed.

This seem to be autogenerated.
I only have Authorization header.
I already see this in your execution_entity Table in data field.

I try to write an accept : application/json header, but it does not work.

Thanks for help.

Find it !

you can surcharge the Accept value if you write it in MINUS…

accept and not Accept

:shushing_face:

Hi, can you send me a picture of how you send the client id and secret, i can’t connect to my Akeneo.

hi @victormiranda the akeneo complete guide : The "Connect the PIM" tutorial

You have to get a token that you can use in your request
how to generate a token


Base64 encoded : Genesys Cloud Developer Center

you get this

call pim api
Bearer {{$node[“Pim Get Token”].json[“access_token”]}}

2 Likes

Thanks you, but inside Authorization’s value (in header) you write the client id and secret.
In what format are they written, all together without spaces?

You have to encode it

Base64 encoded : Genesys Cloud Developer Center

2 Likes

Thanks a lot.

Hi other time,
i have other problem with akeneo, i don’t know but i obtain this error.

I have entered the credentials as you told me.
My server is an instance of akeneo in Aws

Can you past your workflow? And a screenshot of your workflow ?

1 Like

@victormiranda your Akeneo is configured to use a self signed certificate so it can’t be trusted properly, You could look at using Lets Encrypt to create a cert for it or in your n8n project for hte HTTP Request enable the Ignore SSL Issues option.

1 Like

Thanks @Christel_Doudet @jon , its work!

2 Likes

Wonderful! Thanks, @Christel_Doudet and @jon :sparkling_heart:

@victormiranda, can you please share the solution so that other members can easily find it? :slight_smile:

1 Like

It was a problem with the akeneo certificate, adding the option Ignore SLL problems worked.

1 Like