HTTP-Request Node is unable to download files from SeaTable (ERROR: invalid extended field value)

Hey y’all,

First of all, I really want to thank the n8n team for the awesome tool they created, which I’ve been using almost daily for more than a year now. I’m also really impressed by all the support the team and the community provided every time I had a problem I couldn’t solve, and here I am, in need of your help again.

Downloading Content with SeaTable

I use SeaTable to organize and manage invoices and automate a lot of it with n8n. In some of the workflows, I need to download the file to either send it via mail or to let n8n analyze the text (content) of it.

In order to download a file from SeaTable, I need to create an authorized HTTP-Request with an API token and will get back a temporary direct download link, which I can then download with a second HTTP-Request node.

This second node, however, since updating N8N to version 1.x and SeaTable to the latest version 4.1.9 , gives me the error "ERROR: invalid extended field value" every time I try to download the file with the Link I get back from my first request. This used to work and is suddenly broken now.

Interestingly SeaTable doesn’t protect those temporary links, thus I was able to download the file from the same link as the one where n8n gave me the error, using the browser of my phone, Insomnia, an incognito Tab, and the Tor browser, which led me to believe that the error has to be in the code of the HTTP-Request-Node since all other tools and browsers that I used started to download the file immediately without the need to authenticate (like they’re supposed to)

In this example workflow I hard-coded a random working Link and a non-working link that I got back from Seatable. I don’t know if or when the latter link will expire (and thus will throw a 404 or 401 eventually) but I’d be more than happy to provide a new one, in order to help reproduce the error.

Example Workflow:

Information on your n8n setup

  • n8n version: latest
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu

Thank you for reading this, I hope we can somehow find the cause of this error together :slight_smile:

1 Like

Hi @one_juru, I am so sorry for the trouble. Could you upgrade to [email protected] and let me know if you’re still seeing this problem? This should improve the handling of content-disposition headers, which I suspect has caused this problem in the first place.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.