HubSpot - Create a new deal Node Has Problems With Pipeline and Deal Stage

Hey,

So HubSpot has a great documentation and n8n.io is a great platform so I’m trying to put their power together.

I want to create a deal and I need to choose a pipeline and a deal stage

(Check out the screenshot!)

n8n.io’s Create deal node lets you choose only DEALSTAGE and I actually don’t even see the dealstages in other pipelines, esp. the one I want to create the deal in.

Deals are inside a pipeline and inside those pipelines are deal stages.
Like deal ← deal stage ← pipeline

In my CRM there’s several pipelines and those have multiple deal stages.

Do you know there’s anything I can do about that?

I cannot pick the pipeline I want and thus the dealstage I want.

Hi @daghan, first of all welcome to the community!

I could get non-standard stages in custom pipelines to work, but it requires getting the right pipeline ID. Here’s what I did:

  1. Clicking the Add Field button from your screenshot to add the pipeline field.
  2. Enter the ID of your pipeline in the field. HubSpot shows this on the Deals Settings screen when clicking the </> button:
  3. You should now be able to pick your custom stage:
    image

Does this work for you?

Thank you @MutedJam!

This did not work for me if I’m not making any mistakes.

I added the pipeline field and typed in the id of it which is “default”
And then refreshed the stage area but the same deal stage from another pipeline keeps showing up. I don’t understand what makes it appear there.

I tried this with one more unique pipeline id and nothing changed.
It looks like adding the pipeline id to pipeline fields is not having any effect on my end.
And like I said it’s always like fixed to one pipeline out of three.

According to the API, if not pipeline is send, then the default is used. So if you want to set it to the default one you do not need to set the pipeline parameter.

Is it possible that you want to set it to a pipeline that is not the default one?

Tried to reproduce the issue but in order to create more than one pipeline I need a paid Hubspot account.

Hey @RicardoE105

I did not set it to any pipeline at first and n8n.io was always recognizing the third pipeline not the default one. (My first post was about this but it may not be clear.)

@MutedJam told me about using the pipeline field. I tried it to get the deal stages in my default pipeline but n8n.io still gets the deal stages in the other pipeline which is not the default one.

So with the pipeline field or without it n8n always gets the third pipeline’s dela–al stages.

I added the default pipeline because it’s the pipeline I want to have here.

And like I said I also tried another pipeline id (the second one) and the result was the same.

So interestingly n8n.io somehow connects to the 3rd pipeline in my CRM and not the others.

Let me leave two screenshots for your reference.


I have not forgotten about this. During the week, I will try to find a paid account for testing and replicate the issue to fix it or provide a walk-around.

Hey @RicardoE105 because I cannot pick the pipeline and the deal stage I needed to implement another solution.

I first create the deal by sending a custom HTTP request. That way I specify the exact pipeline and the deal stage I want to create the deal in.

So this is how I do it currently. Thanks :slight_smile:

1 Like

Hey,
It’s been a time but I came on this today and wanted to share solution for others.

Indeed n8n connector lists only the stages from default pipeline but for other pipeline’s stages you can specify stage by providing it’s id as a js expression. Just remember to pick the right pipeline in additional options.

M.

2 Likes