Hubspot doesn't work

Describe the problem/error/question

I am connected via OAuth2 with my Hubspot account. I see n8n as app in my hubspot account.
But any hubspot node doesn’t work.
Add contacts: I get a successful execution but no response data and don’t see any new contacts in my hubspot.
Get contact: I can fetch the contact ids (I see them populated in the dropdown of the node) but when I execute the node I get
" Problem in node ‘HubSpot‘
Bad request - please check your parameters"

EDIT: After executing the hubspot node I get this JS error in the console:
frontend-hooks.js:211 Uncaught (in promise) TypeError: Cannot read properties of null (reading ‘type’)
at Object.getExecutionFinishedEventData (frontend-hooks.js:211:70)
at externalHooks.pushConnection.executionFinished (frontend-hooks.js:1034:34)
at Proxy.$m (index-8ab146da.js:21:6727)
at Object.run (index-8ab146da.js:54:15065)
at Proxy.pushMessageReceived (index-8ab146da.js:240:271909)
at WebSocket.sentryWrapped (helpers.ts:98:1)

AND I also tried it with a custom http request - same result “Node executes successfully”, no return data, no result and the js error in the console.

Information on your n8n setup

  • n8n version: 1.3.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud
  • Operating system:

Any ideas?
Thank you!
Br

It goes on and it’s strange:
When I execute the NEXT node I get a new contact in hubspot but without any of the send attributes
I try it again with the Hubspot node and executing the whole workflow

Ok it works as it should, with the Hubspot node. But only when I execute the whole workflow, not if I execute the single node.

Hi @pfiadDi, I am very sorry you’re having trouble.

Are you by any chance using loops or multiple incoming connections? I’ve seen n8n struggling with such scenarios when executing a single node only instead of the whole workflow.

If the problem still persists for you on the latest n8n version 1.18.0, could you perhaps share a minimal workflow using which the problem can be reproduced?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.