Hubspot Form's Fields Not Showing

image

Describe the issue/error/question

When I selected the correct form, the form’s fields are not showing.

How to show the fields/properties so I can match/fills it with correct parameters?

For instance like in automate.io, when I select a form, it immediately displays the form’s properties

What is the error message (if any)?

No error message

Please share the workflow


</>
{
  "nodes": [
    {
      "parameters": {
        "httpMethod": "POST",
        "path": "d3ae8eb1-5490-4225-b197-0dbb29a5c086",
        "options": {}
      },
      "name": "Webhook",
      "type": "n8n-nodes-base.webhook",
      "typeVersion": 1,
      "position": [
        -580,
        160
      ],
      "webhookId": "d3ae8eb1-5490-4225-b197-0dbb29a5c086"
    },
    {
      "parameters": {
        "authentication": "apiKey",
        "resource": "form",
        "operation": "submit",
        "formId": "0a387d82-a82a-475c-95d1-55dcb301a55f",
        "additionalFields": {},
        "contextUi": {},
        "lengalConsentUi": {}
      },
      "name": "Hubspot",
      "type": "n8n-nodes-base.hubspot",
      "typeVersion": 1,
      "position": [
        -360,
        160
      ],
      "credentials": {
        "hubspotApi": {
          "id": "2",
          "name": "HubSpot account"
        }
      }
    }
  ],
  "connections": {
    "Webhook": {
      "main": [
        [
          {
            "node": "Hubspot",
            "type": "main",
            "index": 0
          }
        ]
      ]
    }
  }
}

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.186.0
  • Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]: Own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @yousername, welcome to the community!

Tbh, I am a bit puzzled whether this is the expected behaviour. I’ll add this to our bug tracker for a closer look and will have a quick go to see whether this could be done via the HTTP Request node until we have fixed this.

1 Like

Okay, this worked:

You will need to adjust the URL slightly, the structure is https://api.hsforms.com/submissions/v3/integration/submit/:portalId/:formGuid (source). You can find both your portal ID and your form GUID in the URL when looking at your form in Hubspot:

The authentication is set up like so:

Hope this helps!

Thank you for the response

I have followed the step, I still can’t see the form’s field :pray: :pray:

Oh sorry for the misunderstanding. You won’t see the fields by default, but you can use them inside your HTTP Request node. The example workflow I have shared above does this for three fields, but you can add additional ones as required:

This would send the data structure directly to Hubspot’s API, avoiding the limitations of the existing n8n node.

1 Like

Thank you for your support!

1 Like