Hubspot GET claiming bad parameters bug?

This is how I have my get set up for Hubspot. Note that I’m trying to use a value form a previous node. You can see the value correctly being shown in the hubspot node. However, this is giving me a bad request error:

    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Hubspot/V2/HubspotV2.node.js:2540:31)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:646:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:631:53

If I just enter that same value that the expression is getting (12551), then the hubspot node runs fine.

I’ve tried getting this value directly from a code node, with a set node), I’ve tried getting it as a string and a number and nothing seems to work.

Any suggestions?

You can try with something like this instead of your $json.contactId:
{{ $(NAME_OF_YOUR_NODE).first().json.contactId }}
Is it working?

1 Like

I didn’t make any changes and it just suddenly started working, so wondering if this was a temporary issue with Hubspot’s API.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.