Hubspot node - get contact error

Describe the issue/error/question

Hello - I have a HubSpot Trigger and HubSpot node that gets the contact info. This has been working since last Friday but today when I went to test it again, I’m getting an error on the HubSpot node.

No major changes have been made in the workflow but it’s now asking that “Deal Stage Name or ID” is required when that isn’t a field for this node to fill in.

Is this a bug? The only thing that’s changed is we updated our n8n instance on Wednesday afternoon from 0.182.0 to 0.183.0. I haven’t tested/ran the workflow since the update until today (Friday morning) and that’s when the error popped up.

What is the error message (if any)?

Workflow has issues: Please fix them before executing:

  • Hubspot: Parameter “Deal Stage Name or ID” is required.

Please share the workflow

Information on your n8n setup

  • n8n version: 0.183.0

Same here but with get company

All my Hubspot nodes are nolonger working because of this

Please fix them before executing:

  • Hubspot: Parameter “Deal Stage Name or ID” is required.

@wmuza @tjerk @v6w2x4y2z2

I can’t replicate this in a fresh workflow; could you please provide a copy-paste of your nodes from workflows which are having this issue?

At the same time, could you paste your nodes into a fresh workflow and run again to see whether you get the same error?

I contributed some code to allow updating Ticket Stages but I can’t see how this could be affecting it. I suspect maybe seeing the nodes JSON may help.

See here n8n - Workflow Automation - YouTube


Hey @v6w2x4y2z2,

Welcome to the community :tada:

For now can you roll back to 182 this will get you back up and running, The actual issue itself should be fixed in 184 which is not yet released.

1 Like

@wmuza Thanks for that, turns out the n8n team are quicker and I was running the latest from source which already had their fix.

I’m also relieved it wasn’t what I contributed that caused it! First few pull requests I’ve ever submitted.

Thanks @Jon and team.


@Jon Thank you. Rolling back to 182 worked and things are back to normal. Looking forward to the fix in 184.

1 Like

Hey @v6w2x4y2z2,

The good news is 184 was released earlier today so you should be able to upgrade to it now if you wanted to :+1: