HUBSPOT UPSERT NODE EMAIL NOT WORKING- ERROR: The resource you are requesting could not be found

Describe the problem/error/question

The HubSpot Upsert Node email field suddenly doesnt work. This node uses the email field to match. It’s worked every day since I set it up and now suddenly gives me this error-

ERROR: The resource you are requesting could not be found

If I copy and paste an email into the node instead of using {{ $json[‘Email, Borrower’] }} it works.
When entering {{ $json[‘Email, Borrower’] }} into the email field it does show the correct result below it.

Why is this error all the sudden happening? I thought it might be HubSpot but wouldn’t it not work if I put an email in there? All the other nodes that get information work.

Please Help!

What is the error message (if any)?



Hey @fbrdr,

I replied to your ticket about this earlier :slight_smile: Feel free to pop any replies to it here.

I found the issue after a testing a bit this morning. It was the Google Sheets column naming. I had the email header as “Email, Borrower”. This worked intially but when I started adding on more things I got the error that the email wasn’t being pick up. After changing the column headers to something without a comma like “EMAILB” it all worked.

Be careful with your Google Sheets headers!

1 Like

Hey @fbrdr,

That is good to know thanks for the update.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.