HUE Error - OAuth credentials not connected!

Hi, I have some trouble to get the HUE connector working. I already did create a developer account for some other apps. I just created a new “app” like described here.

I always get the error

Error: OAuth credentials not connected!
    at Object.requestOAuth2 (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:56:15)
    at Object.requestOAuth2 (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/NodeExecuteFunctions.js:419:42)
    at Object.philipsHueApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/PhilipsHue/GenericFunctions.js:24:49)
    at Object.getUser (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/PhilipsHue/GenericFunctions.js:36:54)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/PhilipsHue/PhilipsHue.node.js:105:67)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:489:37)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:369:62
    at processTicksAndRejections (internal/process/task_queues.js:97:5)

What can I do? What are my options to debug to get further details? Is it even a “HUE” problem or what does the error message means

Welcome to the community @josema!

To connect you have to open the credentials and then press on the circular orange button left of “Not connected”
Screenshot from 2020-10-16 16-13-08

After you did that it should work fine.

Hi jan, thanks :grinning:

I just realised that the button is still “Not connected”. If I press the button, I get a message in the lower right corner.

## Credentials updated
"hue" credentials were successfully updated!

But the button remains “Not connected”

Wonder if that is some strange UI issue. Did you close and open the credentials again? Does it then still display “Not connected”?

yes I did. But it is still not connected. I also run the workflow → same result.


Quite weird. Just tested it and it’s working fine for me.

1 Like

If you go back in the credentials does it display them as connected or not? If not, please try to restart the browser and try to connect with the connect button again.

1 Like

I tried it a thousand times … go forth and back, did use a private mode window, cleared the cache and what not

I made it work using another browser. Did finally use the Chrome browser and a pop up appears… it seems that safari was the problem :man_facepalming:

thank you


Isn’t it always?

But thanks a lot for informing us about that. Good to know. However not sure how fast we are able to make it work also in Safari as such things are sometimes more complicated to fix than expected.

same happened to me with a different workflow using Safari. With Chrome the popup appeared and I could login properly but with Safari the popup was not appearing and I was not getting any notification of a blocked popup either

Hey @mukesh_mjn!

Welcome to the community!

This doesn’t look like the HUE node. Can you create a new topic? :slight_smile:

1 Like

Thanks! You saved my day. I was looking for the reason and found no error in what I had already done. In my case I was trying to connect with mautic and firefox wouldn’t open the popup.

1 Like