I cannot add any nodes to my workflows

I’m experiencing an issue with my n8n setup where I cannot add any nodes to my workflows. Whenever I attempt to insert a node, I encounter the following error message:
“Could not insert node ‘n8n-nodes-base.manualTrigger’ is an unknown node type”

im on windows server 2022
when i run n8n from CLI there is no problem and i can work in localhost:5678
but i use nssm to run n8n as a service and then using NGINX for Proxy localhost:5678 to my domain address
when i go to my domain address it loads the sign in page for n8n but nothing works from that point. i even login with different user and i can see wokflow page but i cant add any node to the graph it seems n8n cant find any nodes.

Steps Already Taken:

  1. Verified n8n Installation: Ensured n8n is installed correctly and tried reinstalling with npm install -g n8n@latest.
  2. Cleared npm Cache: Executed npm cache clean --force and reinstalled n8n.
  3. Checked for Multiple n8n Instances: Made sure no other n8n instances were running, especially when attempting to run n8n locally.
  4. Set NODE_PATH Environment Variable: Configured NODE_PATH to point to my global node_modules directory.
  5. Database Lock Issues: Resolved a previous “SQLITE_BUSY: database is locked” error by ensuring only a single instance is accessing the database.

Despite these efforts, the issue persists, and I’m unable to add any nodes, including base nodes like manualTrigger, to my workflows. This problem seems to be impacting the ability to recognize or load the n8n-nodes-base package correctly.

any idea whats the problem.
any hint would be great
thx

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

n8n version : 1.28.0
database : default
n8n EXECUTIONS_PROCESS setting : i didnt do anything with this setting so i assume it should be default
Running n8n via : i run n8n as a service with nssm in windows server 2022 alongside nginx.

Welcome to the community @Vfx_Master !

I am very sorry to hear that you have problems. Is it the first time you installed n8n, or did it work previously with an older version, and you are experiencing this issue after you upgraded?

hi jan
this is my first time installing n8n on my domain
before this i worked in localhost:5678

In this case please follow one of our installation guides here:

You should so end up with a properly running and configured n8n in no time.

We can sadly not help with debugging custom setups.