I cannot add Manychat API successfully. It keep show error

Hi,

I try to add Manychat API ManyChat API (can refer documentation here) But it keep show me error. My setup as below. Hope anyone who have experience can tell me how to solve it. I tried on the Manychat swagger everything works fine.




Hey @jerryyong,

Welcome to the community :racing_car:

That error looks like Manychat is saying you have hit a request limit (api max rps reached) looking at the docs you have provided there is a limit for a 24 hour period.

ManyChat API : ManyChat Help Portal?

At first i having same thought like you. But i try the same API at the Manychat swagger. it works fine. Then i try my another account with new API which never tested at n8n.io. It having the same error. But the same API i tested on Integromat it is working without issue.

Hey @jerryyong,

I suspect location may have a part to play as well, The Manychat doc and the API response seems fairly clear that the issue is with the amount of calls. It could be that your workflow is doing something odd and sending a bunch of requests.

How many input items do you have going into that node? If you are using Header Auth you also won’t need the authorization header in the node itself so you could drop that part of it.

Hi Jon,

I tried your suggestion. But seem not solve the issue. I already try and error all the ways i could. Maybe can you help me how should i do the setting base on the data below?

curl -X GET “https://api.manychat.com/fb/subscriber/getInfo?subscriber_id=1280541638” -H “accept: application/json” -H “Authorization: Bearer 429102:d5609f9d14f482097c75”

Thank you!

Hey @jerryyong,

Are you still getting the 429 error back from ManyChat or something else? Looking at that request if you were to send the header in the node rather than as a credential object it would look like this:

Hi Jon, it is solved now. Thanks!

But i having another issue. Hopefully if you know how to solve, can you please assist? thank you!
Here the post How to set Telegram Text Message to Group?