I have a white page error

I have a white page error with this in console:

Uncaught SyntaxError: Invalid or unexpected token

Can not see login screen and anything else

Hi @cmdntd987, I am very sorry to hear you’re having trouble.

Unfortunately I am not able to reproduce or understand the problem based on the information you have provided. Perhaps you can fill out the template shown when posting a new question here on the forum and describe which steps exactly are required to end up with the white screen and console error you are facing?

Sorry, this is very strange for me with n8n
Could you check at sub.my-n8n.com? It seems still running in background, but I coud not edit or login to n8n editor. I will delete this url soon for security.

Looks good to me, tried to connect with mock data and returned normal error

I tried to go url by incognito chrome (no cookies), but just white screen
It 's very strange
Do you have any idea?

Could you try on your phone with a different network like mobile data ?
Does your desktop browsers returns error in console or network tab ?

It is normal even the same moderm and network
How could it have error when I tried inconito (no cookies)?

I use linux (ubuntu) on chrome
Is there any issue with package upgrade of ubuntu, and delete old not-use packages?

It seems not redirect to login url at white page


Sometimes, I could see login screen at this url in incognito. But sometimes just white page.

Hi @cmdntd987, I am really sorry but just like @MoryCorp I could see the login package when visiting the URL you posted before changing it.

As for the package upgrades you’ve asked about I am not sure. How exactly are you deploying n8n? Are you using docker? If so, the packages on your OS shouldn’t matter as the image n8n itself contains everything needed to run n8n.

Hi I’m having the same issue, sometimes n8n running on current latest, sha id sha256:0df06c996d091d9686ea20fbf040c0c59d5b1ef4827ced975d0fb566f64584e8, cause white screen with error

Uncaught SyntaxError: Invalid or unexpected token (at ParameterInputList-d39ea23a.js:53:9682)

I was able to login previously, but now it always show white screen. I have tried restarting the container and still no effect. Tried different browser also, no luck.

I’m having this exact issue. I’ve deployed n8 using docker


@iFocux @physx911 can you both share more information about how you have n8n set up? Are you using any reverse proxies or caching through cloudflare or similar?

@Jon I’m using docker with Nginx Proxy Manager and using cloudflare as CDN.

Inside docker, I run the n8n image using the recommended way, docker run -it --rm --name n8n -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n, and attach it to the network.

Hey @iFocux,

Part of that is similar to how I have my n8n instance setup to run although I am not using Cloudflare as a CDN. What happens if you try to access your n8n instance directly does that work?

@Jon it works! I open n8n directly from ip using port :5678 and it works, but when I open it on my domain n8n.____.com, it just show blank page. Hmmm maybe cloudflare caching? Let me try clearing cloudflare cache

Yup, it’s caused by cloudflare caching somehow. After I purge the cache from cloudflare, n8n loads correctly, after a few hard refresh (ctrl + f5), n8n display a white screen again. @Jon

1 Like

So I would probably turn off the Cloudflare cache, I can’t think of a reason to actually use it as n8n itself is dynamic to a point and it looks like Cloudflare is making changes to the files to cache them which is never good.

I’m using traefik reverse proxy and Cloudflare. I added a page rule to bypass the cache on the subdomain and it works for now.

1 Like

Sadly, I tested added a page rule to bypass the cache on the subdomain and even disable proxy cloudflare dns, including purge everything on cloudflare cache. But white page still be there, only ok with incognito.

I think there is issue with user cache on browser.
It was ok at old version, not now.

When I try on incognito screen, it is white page at first. But when reload it is ok.
It means not able to redirect at first link, until force browser to redirect to login by reloading.

@MutedJam I use:

n8n on docker, version 0.220.0, included worker and redis
browser: chrome Version 111.0.5563.146 (Official Build) (64-bit)
os: linux, ubuntu (both server & client, my computer)

Sorry about late reply, I am rather busy recently.

1 Like

Hey @cmdntd987,

Do you get the same issue you connect directly?