I'm getting error after installed node-modules 'cross-blob'

image
@jon @RicardoE105 @MutedJam @shrey-42

Hey @AMS_KHADHIRI,

You don’t need to tag us we always know when there are new posts. Do you have the steps you followed to add cross-blob to your install?

I have used like this

Hey @AMS_KHADHIRI,

Did you add it to your n8n install using the npm and did you tell n8n about it with the NODE_FUNCTION_ALLOW_EXTERNAL environment variable?

Just trying to use it will fail so you would have to first add it to the install which would depend on how you have n8n installed if you are using docker you would to add it to the image if you are using npm just an npm install should do it. Once that is done you then need to tell n8n so it can load or it will fail which is where that environment variable comes in.

1 Like

Yes, we use NODE_FUNCTION_ALLOW_EXTERNAL environment variable add cross-blob module. Since we are using Docker, it looks we have to add it to the image as well. Let me try that.

2 Likes