I'm trying to create an api for chatwoot, but when I'm creating it, this error appears and I don't know how to solve it

ERROR: connect ETIMEDOUT 0.0.31.144:80

connect ETIMEDOUT 0.0.31.144:80

{“status”:“rejected”,“reason”:{“message”:“connect ETIMEDOUT 0.0.31.144:80”,“name”:“Error”,“stack”:“Error: connect ETIMEDOUT 0.0.31.144:80\n at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1278:16)”,“config”:{“url”:“188.34.200.22:8080/instance/create”,“method”:“post”,“data”:“{"instanceName":"9whatsapp","token":"","qrcode":true,"chatwoot_account_id":6,"chatwoot_token":"M1GndXQaBXyF3j1jx6fvt1Bf","chatwoot_url":"https://evolution.edutechnology.work","chatwoot_sign_msg":true}”,“headers”:{“Accept”:“application/json,text/html,application/xhtml+xml,application/xml,text/;q=0.9, image/;q=0.8, /;q=0.7”,“apikey”:“B6D711FCDE4D4FD5936544120E713976”,“Content-Type”:“application/json”,“User-Agent”:“axios/0.21.4”,“Content-Length”:200},“transformRequest”:[null],“timeout”:3600000,“responseType”:“stream”,“xsrfCookieName”:“XSRF-TOKEN”,“xsrfHeaderName”:“X-XSRF-TOKEN”,“maxContentLength”:null,“maxBodyLength”:null,“transitional”:{“silentJSONParsing”:true,“forcedJSONParsing”:true,“clarifyTimeoutError”:false},“axios-retry”:{“retryCount”:0,“lastRequestTime”:1697808280805}},“code”:“ETIMEDOUT”}}

Stack

NodeApiError: connect ETIMEDOUT 0.0.31.144:80
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1281:27)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:655:19)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:596:53

Information on your n8n setup

  • **n8n version: 0.236.3 **
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Eduardo_Dias,

Welcome to the community :tada:

Have you changed that error message at all? The IP of 0.0.31.144 looks a bit odd. So looking at the error message it looks like it has just failed to connect the best thing to do in cases like that is add some retry under the nodes settings so if it does fail it can retry it and it should be ok on a future run.

Sometimes services can block a request if they get too many or if they don’t like the request so it could be an odd network issue or the request is wrong.

Thanks for answering me!
No, I didn’t change the error message. I did what you said but I still got the error.

The ip and the port are different :thinking: are you using a proxy at all?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.