IMAP Email node does not retrieve photo in eMail (using iPhone)

Describe the problem/error/question

After reading the docs and many posts, I have managed set up a workflow that retrieves attachments in an eMail (png, jpeg) and then sends them into Wordpress.
However, when I use an iPhone to take a picture in an email (this is the actual use case), the photo does not show up as an attachment (e.g. attachment_0), and therefore the workflow can’t process anything.
How can I get the photo in an iPhone email?

What is the error message (if any)?

Please share your workflow

Thanks in advance for your help!

Information on your n8n setup

  • n8n version: Latest
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Windows 10

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I found the problem:
The eMail trigger node (IMAP) has several settings.
This is the setting that works with inline photos from an iPhone: choose Format: “Resolved”

1 Like

Hey @maraboux,

Welcome to the community :tada:

That is great to hear, I have marked your post as the solution as it will no doubt help others in the future.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.