Imported workflows are not activated even after calling the activate=true in cli

Describe the problem/error/question

I am using the latest version of the N8N: 1.8.2
I have migrated the workflow and credentials with cli and then activated them with using the following command:

n8n update:workflow --id=<ID> --active=true

also when I check the activatation status in the control panel, they are active .

however if I make a webhook request, I get an error that your workflow is not activated and you need to activate it from control panel. what should I do?

What is the error message (if any)?

{“code”:404,“message”:“The requested webhook "GET main-website/faq-list/faq-page" is not registered.”,“hint”:“The workflow must be active for a production URL to run successfully. You can activate the workflow using the toggle in the top-right of the editor. Note that unlike test URL calls, production URL calls aren’t shown on the canvas (only in the executions list)”,“stacktrace”:“ResponseError: The requested webhook "GET main-website/faq-list/faq" is not registered.\n at ActiveWorkflowRunner.executeWebhook (/usr/local/lib/node_modules/n8n/src/ActiveWorkflowRunner.ts:207:10)\n at processTicksAndRejections (node:internal/process/task_queues:95:5)\n at /usr/local/lib/node_modules/n8n/src/WebhookHelpers.ts:110:15”}

Information on your n8n setup

  • n8n version: N8N: 1.8.2
  • Database (default: SQLite) Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: ubuntu

Hi @Ata_Zangene :wave:

Does this error also happen on save or when you click Execute Workflow as well? Is this happening to all your workflows, or just one?

Also, is there any chance you might be accidentally running more than one n8n instance?

Hi @EmeraldHerald

Does this error also happen on save or when you click Execute Workflow as well?
no, if I click execute, that does not happen and everything works well.

Is this happening to all your workflows, or just one?
all workflows

Also, is there any chance you might be accidentally running more than one n8n instance?
Not by accident :smiley:
**I have two instance, one is for user requests ( worker ) and one for managing workflows ( used by admin ), both of them have access to same postgress db and also same encryption key, also in future, I may add many instance to workers **

Hi @Ata_Zangene - one quick question after testing around just there, did you restart your n8n instance? You didn’t mention it in your post, but it is needed as part of the steps: CLI commands | n8n Docs

ohh, sorry me, @EmeraldHerald I did not notice of that, I just restarted that and It seems that everything works well. thank you. I will destroy my whole services and try again to confirm.

Also do I need to restart every n8n node to take affects ? or I can do this just by manager node?

1 Like

Again in my quick testing - and also going by Configuring queue mode | n8n Docs - it looks like restarting the main instance should be enough :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.