'=' in set gets deleted


in order to create a link in an excel-sheet I set a value to ‘=HYPERLINK(“https…”)’

after leavng the node, the ‘=’ gets deleted and the created excelfile does not come with a hyperlinkt but ‘HYPERLINK(“https…”)’ written into the cell.

Any Ideas how to fix that?

escaping the with = did not work.

Hi @JanMrlth1, = at the beginning of a string is used by n8n to indicate expressions. Are you perhaps able to use an expression to return the string you have in mind? Something like {{ '=HYPERLINK("https://www.n8n.io")' }}?


Hi @MutedJam , I already have an expression in the hyperlink.
When I put == in the expresion and run it manually I get ==HYPERLINK… in the File. Every time I open the node, one ‘=’ gets delete until none is left.

Even when I get the rigth values in Excel, it does not calculate the formula, and I have to activate every filed. So I will not continue with this workflow.

Thank you for your Help!

Hey @JanMrlth1, so the value added to your sheet looks good to me and exactly one equal sign is coming through. Can you confirm which n8n version and which node exactly you are using (as there are multiple nodes to interact with Excel files)?

A workaround that I have found for this until it gets fixed is as follows:

  1. Add == to the beginning of the equation you want to send
  2. Make sure that “Options” → “Cell Format” → “Let Google Sheets Format” is selected
  3. Close the node
  4. Click “Save”
  5. Open the node and dont touch anything
  6. Close the node again
  7. Click “Save”

This process is a bit annoying but seems to save it with the = at the beginning and pass that equation through.

One thing you can do to reduce the number of times you have to do the above if you are editing that node a bunch is to put the equation into a Set node and then pass that value into your excel/google sheets node.

Even better work around is to use the Set node, set a String and use the following as the value:

{{ “=”: value}}=

The {{ “=”: value}} returns empty, so all that is left on the output is =

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.