Increasing webhook test execution timeout from 120 seconds

Describe the issue/error/question

When testing webhooks, the external site sending the webhook can take 5-10 minutes to send the webhook. Clicking the button will only listen for a webhook for 120 seconds. Is there a way to increase this (without building the app from scratch)? I didn’t see anything in the environment variables but possible I missed something.

Information on your n8n setup

  • n8n version: 0.158.0
  • Database you’re using (default: SQLite): postgres
  • Running n8n with the execution process [own(default), main]: docker
  • Running n8n via [Docker, npm,, desktop app]: docker, via cloudron
1 Like

No, that is currently sadly not possible. That timeout value is hard coded into n8n and can so not be changed without building it from source.

1 Like

@ianhyzy feel free to post (or change this) to a feature request. This way the suggestion can collect votes from the community and has a better chance of being implemented.

For the proposed feature itself, would it be sufficient to have a parameter in a specific node’s “Settings” that can override this default listening time?


yeah while testing webhooks, sometimes it does time out too fast while we are waiting for other stuff

Yup, I posted a FR after I got confirmation here: Allow increasing webhook timeout