Installing community node, appears in workflow but not in API credential

Describe the problem/error/question

I have the self-hosted n8n version installed with Docker. The tests and templates I have created work great. I was trying to install the community nodes, specifically Vikunja, both via the GUI and command methods.

The problem I am facing is that it appears in the workflow, but I cannot add the API Credential.

I have restarted the container and tried versions 1.41.0 and 1.42.0, but the problem persists.

What is the error message (if any)?

Please share your workflow

330928706-ac58b3b5-8a80-4b80-a736-987f38b91272
330928709-29af2301-7ef3-4b53-a637-cb358a777a35

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
    1.41.0 and 1.42.0
  • Database (default: SQLite):
    SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
    main
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
    Docker
  • Operating system:
    Debian 12

Welcome to the community @Niskeletor :tada:
For any issues related to community nodes, I suggest reaching out to the creator of the community node (GitHub - go-vikunja/n8n-vikunja-nodes) I just tried out their newest version v0.1.3 and it seems to be working for me!

3 Likes

Hello! Thank you for the warm welcome :slight_smile:

I did initially report the issue on Vikunja’s GitHub, and they managed to fix it in just 12 hours. I opened this thread because it seemed like the plugin was working for other users initially.

Thank you for your time and for checking with the other repository as well!