Is baserow and merge node bug?

It’s been a day googling and looking around the forums I’m not sure if this suppose to happen or am I doing something wrong here?
This is my node setup


I kept video ID’s in Baserow and I’m fetching any similar vid ID that comes from the YouTube API but

Isn’t the expression should be loop the other incoming data? instead it only search for 1. I checked if YouTube APIdid send them to Baserow node:

they are there, yet only 1 are being used in the expression search term…

and finally in the merge node I’m only receiving incoming data from input 2 only I tried plugging vice versa and only data from input 2 is visible in the expression selection
4

I’m really confused here please help ( T .T) I’m worried if I installed n8n wrong and cause some issues backend though I followed the documentation properly (it’s my first time using docker). Initial installation of n8n, the container doesn’t retain its data after exiting docker but after the update it’s somehow fixed…

Hi @ReMiKU,

What does the merge node show when you give it a test run? The nodes should loop all the items so it could be something odd in the nodes or maybe it is working ok and just not showing you everything.

Hello @jon,

In the merge node it has the youtube api output:


but in the Property Input 1 expression it doesn’t have the youtube api incoming data

Hey @ReMiKU!

The Expression Editor only shows the first item. However, your node will process through all the items.

In your Merge node you’re passing the values via the Expression, however, you only have to mention the keys and not the values.

Below is how my workflow would look like:

And the Merge node will be as follow:

I hope this helps :slight_smile:

2 Likes

Hello @harshil1712,

It is as you said they should be processing through all the incoming items but then I’m confused as to why baserow node is not processing all the items though it looped the correct amount of time :L

Oh!? I didn’t know you could use key instead of expression value thanks but uh… I followed your example and it doesn’t seem to work?


Property Input 1 should’ve give the value “PqJNc9KVIZE” which should remove 1 and only 4 output remains.

Also I’m curious is there a doc for the key use? because does this method also works in other nodes or only merge? with specific mode? I tried it on another node and it doesn’t work :L like in the set node it outputs the key name instead of the item value carried from the previous node.

Hey @ReMiKU!

The screenshot that you shared in the earlier post suggested that you are getting the values from Baserow. Can you please help me understand what is your exact use case? Do you want to append the data to Baserow, or do you want to fetch the data?

Ah sorry @harshil1712, This workflow I’m working on is to both fetch and create data in baserow if the given data from youtube api doesn’t exist. The part where I’m having issues right now is trying to fetch data from baserow to then be compared at merge node.

Hey @ReMiKU,

Thanks for clearing that up. I created a workflow that appends only the new information to Airtable. You can take a look at it here: Add only new records to Airtable

Hey @harshil1712,

Oh!? I didn’t know you could use key instead of expression value thanks but uh… I followed your example and it doesn’t seem to work?
https://community.n8n.io/uploads/default/original/2X/6/6268b2a6941553dba3501cc3e7a4c62fa8dd03e4.png

Sorry! I just realized I uploaded the wrong screenshot I meant to give you this one:

Thanks for the alternative, I was curious and did some testing
Now I understood how the merge node works with the key and such. I don’t understand why input 1 is not visible in expression but the data is there…
I also compared return all to filtering, return all seem to run faster. I were expecting filter would’ve run faster but that wasn’t the case. Also I still don’t understood why it filtered only the first item then looped for the amount of incoming data… and AirTable didn’t loop but only return the first.

With all that said, Thank you for the help! I switched from filter to return all
solved1
and modified your example a little


now it works ( ^ .^)

1 Like

Wonderful! In the Merge node you need to specify the exact key. You’re becoming an expert :rocket:

Thank you @harshil1712 it wouldn’t have been possible without your help!

2 Likes