Is the refresh token for Raindrop used?

Hello n8n Community!

Describe the issue/error/question

I have several workflows that include Raindrop. They all work fine for a few weeks and then they all stop working. The connection still seems to be in place when I look at my integrations within n8n as I see a green bar and checkmark. If I say “reconnect” and actually reconnect, my workflows start working again.

What is the error message (if any)?


Information on your n8n setup

  • n8n version: 0.188.0 (will update to latest version today)
  • Database you’re using: default for Docker container
  • Running n8n with the execution process: Running via Docker
  • Running n8n: via Docker

Hi @colleen, the raindrop credentials are built on top of the generic OAuth2 credentials implemented in n8n, meaning n8n would try to fresh it when a call fails because the token has expired (or runs into a 401 status).

Is there a chance you’re using the Raindrop node only occasionally? If so, the refresh token might have also expired (this came up recently for a different service). Could you try implementing a dummy workflow that simply reads some data in regular intervals to see if this prevents the credentials from expiring?

Thanks @MutedJam.

I have several different workflows that check once an hour to see if there is new data in a particular Raindrop collection. If there is, data goes to Airtable. One workflow in particular finds a few items in Raindrop each day. The others don’t always have data to send.

It seems like all the workflows fail on the same day. It’s always a few weeks after I last “reconnected” n8n and Raindrop. Since I just reconnected the services, I don’t expect any issues for a few weeks. When it happens again, I can record a video of what’s happening and the steps I take.

Thanks so much for confirming @colleen. Sounds like there is a problem with the Raindrop refresh logic. With their tokens expiring every 2 weeks I have not been able to fully test this yet but shall add this to our bug tracker for a closer look by the team.

Please accept my sincere apologies for the inconvenience this causes.

Just add a change that should fix this. I did not test it because the access token expires every two weeks. It will be available in the next release. It would be awesome if you could confirm whether this fixes the issue.

1 Like

Awesome, thank you so much @RicardoE105!

Thank you @MutedJam and @RicardoE105.

Timing bugs can be hard to test. Thanks again!

1 Like

Got released with [email protected]

I am once again having trouble with my flows that use Raindrop.

I had been having errors here and there, but wasn’t concerned. Starting 10/27, it’s been failure after failure after failure on multiple flows that use Raindrop.

I’ve tried re-authenticating with Raindrop.

Error: UNKNOWN ERROR - check the detailed error for more information
last node that was executed was Raindrop Get Bookmarks.

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
    at Object.raindropApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Raindrop/GenericFunctions.js:30:15)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Raindrop/Raindrop.node.js:125:40)
    at async Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:658:28)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:562:53

My version of n8n has been upgraded.
n8n Version 0.200.1

I currently have exactly the same problem. Would be great if this could be fixed

Hey @colleen & @amalgam,

Would you be able to open new threads? The issue in this one has been as solved so we will need to work out if it is the same issue or something else. Looking at the error message I suspect it is a different issue.

@Jon and @amalgam - I created a new thread.

1 Like