Issue on compiling in a dockercontainer

Well that is strange, I am not seeing anything jumping out in the logs. When I check in VScode I don’t see that same issue

I am starting to think it might just be a dependency issue, Can you try the latest version of n8n and see if that works as expected? Looking at our own builds of the container we are not seeing the same issue so it sounds like it is potentially something local.

Okay so I tried on a fresh, updated repo and that worked
will now try what happens when I add our custom nodes to it

Seems to somehow be a dependency Issue I guess since on the fresh repo even after adding the custom nodes it is working with no issue.

1 Like

That is good to hear, So I guess if you wanted to stay with the older version it would be a case of checking the depencies to see what has changed since the older version. I know we moved to Node 16 because of some issues a while back so it could just be that.

Yeah I will check with the others and maybe see if I can find the issue.
Anyway, thanks for all the help.
Had no idea where to start since the error-message was not helpful for us at all.

1 Like

To be honest it wasn’t very useful for me either but I am a big fan of always trying the newest release to see if it solves an issue if it doesn’t then it isn’t something already fixed or a dependency oddity.

@Bennse It looks like the version of VUE is not pinged well.

My solution is:

  1. pin vue as "vue": "2.6.11" in both files
    • packages/design-system/package.json
    • packages/editor-ui/package.json
      Note: I removed the ^ to ensure it’ll install 2.6.11 instead of 2.7.x
  2. pin this package as “vue-template-compiler”: “2.6.11” in both files above
  • add package “https-proxy-agent”: “5.0.0”, in any of both files above.
    Note: I knew it might not be a good place to put, but it works
1 Like