Issue with active webhook/HTTPRequest

My workflow works fine when the workflow is inactive, webhook request triggered by postman.

When workflow is activated, the HTTPRequest call on the 3rd iteration failed.

There isn’t a $count parameter sent so I’m not sure where that bit come from.

Based on the previous result, the 3rd HTTPRequest would return a blank array []. Does the HTTPRequest node react differently during an active workflow?

Information on your n8n setup

  • n8n version: 0.2262
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system:

HI @engowen

From a first glance I think one or more of the values in the URL aren’t filled properly making the HTTPreq making a call to a different url endpoint that does need the $count.

The preview can be misleading some times. When you are testing, do you also use multiple items and the same input? As it seems to go wrong with the 3rd call you have something specific to look for. :slight_smile:

1 Like

Thanks for suggestion, the vendor system always make 2 calls simultaneously, hence it isn’t possible to use 1 workflow for test unless enable as active that the webhook continue to listen to the call.

I’d make the effort, separating the metadata webhook from the response service in order to see what’s going on. And I found the culprit. Apparently the caller system auto wrapped my defined query with “$count=true” :dizzy_face:

So this is none issue on n8n. :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.