Issue with an API response and HTTP request node

Hello,

I use an HTTP request node to pull an HVAC Airzone controller.

But the answer is not well interpreted at the output of the node :

[
  {
    "data": "{\r\n\t\"data\":\t[{\r\n\t\t\t\"systemID\":\t1,\r\n\t\t\t\"zoneID\":\t1,\r\n\t\t\t\"name\":\t\"Bureau GR\",\r\n\t\t\t\"thermos_type\":\t4,\r\n\t\t\t\"thermos_firmware\":\t\"3.31\",\r\n\t\t\t\"thermos_radio\":\t0,\r\n\t\t\t\"on\":\t1,\r\n\t\t\t\"double_sp\":\t0,\r\n\t\t\t\"coolsetpoint\":\t21,\r\n\t\t\t\"coolmaxtemp\":\t30,\r\n\t\t\t\"coolmintemp\":\t15,\r\n\t\t\t\"heatsetpoint\":\t21,\r\n\t\t\t\"heatmaxtemp\":\t30,\r\n\t\t\t\"heatmintemp\":\t15,\r\n\t\t\t\"maxTemp\":\t30,\r\n\t\t\t\"minTemp\":\t15,\r\n\t\t\t\"setpoint\":\t21,\r\n\t\t\t\"roomTemp\":\t21.2,\r\n\t\t\t\"sleep\":\t0,\r\n\t\t\t\"temp_step\":\t0.5,\r\n\t\t\t\"modes\":\t[1, 4, 2, 3, 5],\r\n\t\t\t\"mode\":\t3,\r\n\t\t\t\"speed\":\t0,\r\n\t\t\t\"coldStage\":\t1,\r\n\t\t\t\"heatStage\":\t1,\r\n\t\t\t\"coldStages\":\t1,\r\n\t\t\t\"heatStages\":\t1,\r\n\t\t\t\"humidity\":\t50,\r\n\t\t\t\"units\":\t0,\r\n\t\t\t\"errors\":\t[],\r\n\t\t\t\"air_demand\":\t0,\r\n\t\t\t\"floor_demand\":\t0,\r\n\t\t\t\"cold_demand\":\t0,\r\n\t\t\t\"heat_demand\":\t0,\r\n\t\t\t\"heatangle\":\t0,\r\n\t\t\t\"coldangle\":\t0,\r\n\t\t\t\"master_zoneID\":\t1,\r\n\t\t\t\"eco_adapt\":\t\"off\",\r\n\t\t\t\"antifreeze\":\t0,\r\n\t\t\t\"open_window\":\t0,\r\n\t\t\t\"heat_angle_values\":\t[90, 50, 45, 40],\r\n\t\t\t\"cold_angle_values\":\t[90, 50, 45, 40],\r\n\t\t\t\"heat_angle_conf\":\t90,\r\n\t\t\t\"cold_angle_conf\":\t90\r\n\t\t}]\r\n}\r\n"
  }
]

Is there a way to parameter the node so all those typewriters stuff get well interpreted ?

Information on your n8n setup

  • n8n version: 1.17.1
  • Database (default: SQLite): PostGreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queue
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Raspbian

I found by myself, it’s response format autodetection that does not work well on that response.

If I switch to JSON, it works OK.

1 Like

This topic was automatically closed 7 hours after the last reply. New replies are no longer allowed.

Hey @mcc37,

That is good to hear, I wonder why it didn’t autodetect that though.

1 Like