Issue with inputData being null

Hey Folks,

I have an Asana Webhook node that sends data into a switch statement. This switch statement in turn sends more info to a second switch statement which comes out at a Clickup node. However the clickup node thinks that there is no input data but any other node like a function node can tell that there is input data and log it to the console.

Has anyone seen this behaviour or knows what I might be doing wrong?

Welcome to the community @jaitaiwan!

Not sure if I a following. Can you please post a screenshot of the executed workflow. Thanks!

Hey Jan,

That’s the overall workflow. Here’s the output of 1 on the Action Type (Switch) node:

However the ClickUp node is having many issues:

Note how the GID is populated in the left hand side with inputData but the expression editor can’t tell what the value is. Funnily enough adding a noOp node in between fixes the issue:


But that’s not a workable solution…

I also note that if there are 0 results for the ClickUp node it doesn’t seem to execute the next task despite the continue on error flag.

If I was to add “always output data” it works but then I have an empty object and then the IF node seems to be unable to determine which branch to take if I add one:

If I click “play” on the If node it never recieves data from the ClickUp node even with “Continue on Fail” and “Always output data” selected.

Thanks in advanced for your help.

About your issues.

The editor-UI is currently only able to preview the data from the first output of a node. For that reason does it not resolve them. A work-around for that is to add a No-Op node (or any other) to each of the outputs, as you already did. It will then resolve fine as that node has only one output and that output will have the data. All of that is just needed to display the data in editor-UI, if you execute the workflow normally it will also work fine without, so is a workable solution.

Yes, that is correct. If a node does not output any data it stops that branch. After all, if there is no data for the other nodes to execute they can not execute. That is also not an error. If you make a query to ClickUp that does not return any results, that is totally correct and no error. An error is if something goes wrong. if I have the numbers: 1,2,3,4 and then ask to give me the numbers that are larger than 5 and I get nothing in return, that is correct. Exactly the same here. Only if something goes wrong in the node execution and it can not do what it is supposed to do, like the ClickUp API can not be reached or returns an error, will the node error and then his option will have an effect. What you want is that it always outputs data. So you have to set the option “Always Output Data”. What n8n does then, is that if a node does not return any items, it returns an empty item anyway and the flow then keeps on executing.

Sorry, do not understand the part “then I have an empty object and then the IF node seems to be unable to determine which branch to take if I add one”. The IF-Node should then work totally fine. You just have to tell it what to do. You can set an expression to recognize an empty item and then route depending on that. Or you can set an expression which accesses the data from a previous node or a combination of both.

No idea why pressing “play” on the IF-Node would not work. But if you do that it, reuses existing data in the flow and it is quite possible that there is a bug somewhere and some things work not perfectly. So if you want to get the 100% correct result, you should press “Execute Workflow” that it executes from the start.

Thanks Jan,

That information helped me sort things out.

Happy to hear. Hope we can improve the editor-UI over time.

Have fun!