Issue with WooCommerce node (create: product) "stock_quantity"

The action of creating the product does not send the number of the quantity, I have tried to set also other related fields such as the stock but “stock_quantity” null

Thanks for support


Information on your n8n setup

Sounds like we don’t submit that particular field properly to the WooCommerce API. Perhaps @Jon can check whether the node might need an update?

Hi @Kenlog and @MutedJam,

In order for the WooCommerce API to recognize a stock quantity on product creation, you must also pass it the ‘Manage Stock’ parameter, as without it, the product’s inventory management is not enabled, and therefore it does not recognize the inventory quantity sent to it.

The WooCommerce node works correctly, and creates the product with the indicated stock.


1 Like

@martinhache thanks a lot it works!

One less thing for me to dig into :slight_smile:

1 Like