Issues with GMAIL connection and redirect URI

I am trying to guild a GMAIL trigger. But getting error all the time:

Checked Redirect URI in Google Console thousand times :slight_smile: I even tried adding www subdomain to my subdomain. Read articles on Google and don’t get it. By the way yesterday had the same Redirect URI issue with Slack APP. Maybe n8n has some issues with cache or smth.

Hands down. Please help.

Hey @Saravicius,

When you added the webhook_url did you also include the protocol? so or is it set to just

Yes! Google doesnt accept URIs without protocol

Hey @Saravicius,

The Google bit is fine the bit I am curious about is the n8n setting as we will automatically add the URL so if the setting is not configured correctly there you would have an incorrect url.

Can you elaborate on that more? What do you mean by “n8n setting”? Is this something global n8n or related to the configuration of GMAIL Oauth settings?

Here is a video of my node and settings: Monosnap

Hey @Saravicius,

When you set up n8n you would have set the WEBHOOK_URL environment option, Looking at your recording the callback URI in n8n does not have the protocol set and updating this config key will fix your issue.

Thanks @Jon worked!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.