Issues with Scheduled Trigger Custom(Cron) After Update to 1.27.2

Describe the problem/error/question

I have a several workflows that use the Scheduled Trigger node configured with a custom cron expression (*/15 7-19 * * 1,2,3,4,5). All of them have started reporting errors after I updated to 1.27.2 over the weekend. Non custom options work fine but I can’t get anything to work when Custom(Cron) is selected as the Trigger Interval.

What is the error message (if any)?

Invalid cron expression

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:1.27.2
  • **Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):Docker
  • **Operating system: Ubuntu 20.04.6 LTS

Hey @chadgriff1,

What version of n8n were you on before the update and what timezone do you have set for n8n and your workflow?

@Jon Thanks for getting back to me. I cannot tell you what version I was on as I don’t have logging enabled (but plan to get that setup in the near future). However, I did check each of the three workflows where I use the Scheduled Trigger node and found the time zone set as Default which was not a valid time zone. Upon setting the local time zone on each of the three workflows, the Custom Cron option worked as it did before. Setting the time zone fully resolved the issue.

1 Like