Json deformatting when I change the test url to production url

Describe the problem/error/question

contextualization: I’m pulling value inputs for variables defined through typebot, I pull it through the webhook on n8n and when I run this path with the test url it works perfectly. However, when using the production ulr, my body, which is where the variables are written with their respective values, is unformatted. The Body comes all together and so I can’t call it up in the next step, which is with Google Sheets.

What is the error message (if any)?

none

[image]

Please share your workflow

in a url test:

[

{

“headers”: {

“connection”: “upgrade”,

“host”: “164.68.123.17:5678”,

“content-length”: “176”,

“user-agent”: “got (GitHub - sindresorhus/got: 🌐 Human-friendly and powerful HTTP request library for Node.js)”,

“content-type”: “application/json”,

“accept-encoding”: “gzip, deflate, br”

},

“params”: {

},

“query”: {

},

“body”: {

“message”: “This is a sample result, it has been generated :arrow_down:”,

“submittedAt”: “2024-01-11T04:13:48.785Z”,

“CPF”: “20”,

“nome”: “answer value”,

“email”: “answer value”,

“nume”: “20”

}

}

]

now url production:

[

{

“headers”: {

“connection”: “upgrade”,

“host”: “164.68.123.17:5678”,

“content-length”: “130”,

“sec-ch-ua”: "“Not_A Brand”;v=“8”, “Chromium”;v=“120”, “Google Chrome”;v=“120"”,

“sec-ch-ua-platform”: ““Windows””,

“sec-ch-ua-mobile”: “?0”,

“user-agent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36”,

“content-type”: “text/plain;charset=UTF-8”,

“accept”: “/”,

“origin”: “https://bot.chatflowsc.com.br”,

“sec-fetch-site”: “same-site”,

“sec-fetch-mode”: “cors”,

“sec-fetch-dest”: “empty”,

“referer”: “https://bot.chatflowsc.com.br/”,

“accept-encoding”: “gzip, deflate, br”,

“accept-language”: “pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7”

},

“params”: {

},

“query”: {

},

“body”: "{“submittedAt”:“2024-01-11T12:45:49.979Z”,“CPF”:“20”,“nome”:"answer value “,“email”:“answer value”,“nume”:“20”}”

}

]

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:1.22.4
  • **Database (default: SQLite):how can i get?
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):default
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):cloud
  • **Operating system: windows 10

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Okay, now I added the missing information

Hey @Henrique_Sia,

Are you able to capture the request that Typebot is actually sending? Looking at the header information you have shared it looks like the data is being sent from 2 different systems

I managed to do it, in reality my typebot was unformatting the submission, it wasn’t as .json, now I changed the submission format and my program is running as it should. But thank you very much

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.