JSON with multiply items to table for DB import

Hi,

I’m trying it put data in by BD from a rest call and after hours of searching and testing, I can’t figure this out.

The JSON response from the rest call looks like this:

[
  {
    "body": {
      "entities": [
        {
          "entity_type": "AssetList_c",
          "properties": {
            "LastUpdateTime": 1662726104868,
            "Id": "16909",
           "DisplayLabel": "Car"
          },
          "related_properties": {}
        },
        {
          "entity_type": "AssetList_c",
          "properties": {
            "LastUpdateTime": 1662726124614,
            "Id": "16910",
           "DisplayLabel": "Room"
          },
          "related_properties": {}
        }
      ],
      "meta": {
        "completion_status": "OK",
        "total_count": 2,
        "errorDetailsList": [],
        "errorDetailsMetaList": [],
        "query_time": 1663864636818164
      }
    },
    "headers": {
      "date": "Thu, 22 Sep 2022 16:37:16 GMT",
      "content-type": "application/json",
      "content-length": "411",
      "connection": "close",
      "server": "nginx",
      "vary": "Accept-Encoding, Accept-Encoding",
      "x-correlation_id_header": "RID-2ccb920b-de40-4fc7-a459-3c3ca4c5a21d",
      "token_creation_time": "1663864620000",
      "token_idle_time_up": "60",
      "set-cookie": [
        "JSESSIONID=218EE8D27FCDEE06ABCCD899B2355A82; Path=/; Secure; HttpOnly",
        "TENANTID=113222937; Domain=saas.microfocus.com; Path=/"
      ],
      "x-tenant-version": "v23",
      "access-control-expose-headers": "X-TENANT-VERSION",
      "x-server-elapsed": "32",
      "ems-cache": "false",
      "cache-control": "no-cache",
      "expires": "Thu, 22 Sep 2022 16:37:15 GMT",
      "x-ua-compatible": "IE=Edge",
      "x-xss-protection": "1; mode=block",
      "x-content-type-options": "nosniff",
      "strict-transport-security": "max-age=15724800; includeSubDomains",
      "x-frame-options": "SAMEORIGIN"
    },
    "statusCode": 200,
    "statusMessage": ""
  }
]

And I’m only interested in Id and DisplayLabel.

I can’t solve how to get around/solve the “Item: 0” and "Item: 1) part:
image

I’ve tried both Function but I have minimal knowledge of JavaScript.
I’ve also tried Item Lists but can’t get it to work there either.

Any idea?

Hey @Cizco,

Give the workflow below a bash, The trick was to use dot notation with body.entities in the Item Lists node.

2 Likes

Hi @Jon,

Thank you so much!! This works great :smiley:

1 Like

Hey @Cizco,

That is good to hear :raised_hands: happy automating :tada:

1 Like