Latency of the workflow for telecommunication applications

Describe the issue/error/question

As a telco company we are investigating the possibility to use n8n for creating application servers. This requires the workflow to have an output latency (between incoming api call and outgoing webhook response) of around 50-200 msec maximum. During our investigations -using Linux desktop docker- we experience latencies of around 2500 ms for a very simple (non-mysql qyery) webhook to response workflow. That range is unuseful to telecommiunicatiopn applications.

The question is: can we reduce that response latency realistically to 50-200msec per workflow by settings?

What is the error message (if any)?

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]:

Hi @sl-tobe, EXECUTIONS_PROCESS=main should already speed up responses from n8n as much as possible as it avoids spinning up another node.js process for your workflow execution.

With this setting, a simple workflow like below results in response times around ~40 ms for me:

That’s a single instance on docker behind a caddy reverse proxy with no additional proxy (such as cloudflare) in front. So, in a first step you might want to set up a simple test webhook workflow like this, send a few requests and measure the response times. This should give you a good baseline for further experimenting (such as which impact a different web server would have, or if a faster CPU changes anything). You can then add the nodes from your original workflow into the mix one by one to identify which impact each one might have.