Mouse dragging not working in latest Windows desktop app

Describe the issue/error/question

We are huge fans of n8n and how helpful the lovely devs are so thought it wise to bring this up (couldn’t find a ‘bug’ category although it could be on Github.)

Took a ~year long break from n8n in the hope the issues with the Windows desktop version would be rectified. Have just tried the latest Windows desktop version again on a couple of Windows 10 machines and it is now intermittently preventing any canvas dragging (i.e. with any mouse button held down with/without SHIFT, CTRL or ALT held down.)

Restarting n8n resolves the issue but it usually returns within a few seconds. Have completely cleansed the machines from n8n and re-installed, tried on fresh Windows installs, etc. but issues still persist.

(Some side thoughts regarding the Widows desktop app in the hope it helps the devs out: Not necessarily related to this bug report but globally, Windows users still make up ~75% of all users. Being Windows users, there is a higher probability these are the types of users who will require n8n Cloud. This could become a huge revenue stream for n8n. Of course, it’s easier for the lovely devs to concentrate on Linux but by not ensuring the Windows desktop app is consistently operating perfectly, that risks cutting off that huge 75% of potential paying userbase, especially as Windows users are likely much more fickle when it comes to things not working perfectly even for a second. Again, not necessarily related to this bug report but just something to help increase revenue.)

What is the error message (if any)?


Please share the workflow


Share the output returned by the last node


Information on your n8n setup

  • n8n version: latest Windows desktop version from the website
  • Database you’re using (default: SQLite): n/a
  • Running n8n with the execution process [own(default), main]: ?
  • Running n8n via [Docker, npm,, desktop app]: Windows desktop app

I had the same sort of mouse dragging issues with the windows app - (I thought it was just me : ) .
What I have been doing was simply running the Windows app in the background and loading the desktops n8n via a browser via: http://localhost:5679

I know that it doesn’t really “solve” the issue, yet I just wanted to share a workaround worked for me.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.