Move new subscriber from MailChimp to HTTP Request Node

Is it possible to move each newly created subscriber from MailChimp to HTTP Request Node and auto delete from MailChimp list.

@mcnaveen not sure if I understood well. You can have the Mailchimp Trigger connected to the HTTP node and After that use the Mailchimp Node to delete the person from the list.

This is what I want to Achieve.

Whenever the user subscribes to the Mailchimp list. n8n should trigger and get the data and send it via HTTP Request node to Automizy

I have everything related to Automizy like API URL, KEY.

But I can’t connect the Start Node with Webhook & Webhook to MailChimp Trigger.

How to do this bro?

Why do you want to connect the Start-Node? There should be no need.

What is the Webhook-Node for? What starts the workflow and receives the information is the Mailchimp Trigger node. So also that should not be needed.

There is no way I can delete that from Workflow editor.

Also, Mailchimp trigger showing the localhost URL. Can I replace that with actual domain name?

And I’m getting these errors.

There was a problem and the workflow could not be activated:
400 - {“type”:“http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/",“title”:"Invalid Resource”,“status”:400,“detail”:“The resource submitted could not be validated. For field-specific details, see the ‘errors’ array.”,“instance”:“f2c1cf16-c310-46d6-a212-b134885c3054”,“errors”:[{“field”:“url”,“message”:“Webhooks are no good without a valid URL. Please enter one.”}]}

There was a problem running the workflow:
Test-Webhook can not be activated because another one with the same method “GET” and path “a505d972-8809-41bc-872e-bb307cadf60e/webhook” is already active!

There is no way I can delete that from Workflow editor.

Ah yes, you can not delete the Start-Node, but that does not mean you have to connect it.

Also, Mailchimp trigger showing the localhost URL. Can I replace that with actual domain name?

Yes, that is described in the documentation here:
https://docs.n8n.io/reference/configuration.html#webhook-url

There was a problem and the workflow could not be activated:
400 - {“type”:“http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/",“title”:"Invalid Resource”,“status”:400,“detail”:“The resource submitted could not be validated. For field-specific details, see the ‘errors’ array.”,“instance”:“f2c1cf16-c310-46d6-a212-b134885c3054”,“errors”:[{“field”:“url”,“message”:“Webhooks are no good without a valid URL. Please enter one.”}]}

The problem there is I guess that you use an “http” URL and it probably only allows “https” ones. So you either have to use the tunnel or set up n8n under its own domain/subdomain.

There was a problem running the workflow:
Test-Webhook can not be activated because another one with the same method “GET” and path “a505d972-8809-41bc-872e-bb307cadf60e/webhook” is already active!

That could be two things:

  1. There is another webhook already active with the same path as the error message says
  2. You are using an old n8n version which did not delete webhooks where there were issues creating them (as you had above). In this case upgrade to the latest n8n version.

This is the latest version I got from Docker bro.

I’ll try to fix the other stuff and update you asap.

Then I guess it must be #1 unless there is another bug we are currently not aware of.

Trying to figure out from past couple of hours.

HTTP Request Node returning 403

Here is the API Documentation: https://developers.automizy.com/automizyrestapi/#Creatinganewcontactonalist

Also, How to update to the Latest version (Installed via Docker)

403 is normally used if credentials are not valid (or missing). Are you authenticating correctly?

Here another topic which talks about updating:

MailChimp Trigger works Great. It identifies the last added subscriber. But the HTTP Request Node is throwing 403 Error.

Here is the whole thing:

Exactly that is where the problem would be and also is. If you check the documentation of Automizy here:
https://developers.automizy.com/automizyrestapi/#Authentication

You can find this example:

{
  "Authorization": "Bearer <ACCESS TOKEN>",
  "Content-Type": "application/json",
  "Accept": "application/json"
}

So you have to set “Authorization” to "Bearer ".
You however currently set “Bearer” to “”.
If you fix that (and nothing else is wrong) it should work fine.

Which one I have choose on Authentication?

  • Basic Auth

  • Digest Auth

  • Header Auth

  • OAuth1

  • OAuth2

  • None

This is where I got confused

Either “None” like you have right now and then set it yourself in the header or “Header Auth” and then set it in the credentials (better as then the credentials do get saved encrypted).

Let me try it

Finally Authorization worked.
I have one more doubt.

This is the data returned by MailChimp Trigger.
Selection_178

How to set the value of Email which I got from MailChimp Trigger?

Selection_179

I tried to put data[merges][EMAIL] in value field of Body Parameters (Above Screenshot)
and it’s returning this error.

ERROR: 422 - {“validation_messages”:{“email”:{“emailAddressInvalidFormat”:“The input is not a valid email address. Use the basic format [email protected]”}},“type”:“http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html",“title”:"Unprocessable Entity”,“status”:422,“detail”:“Failed Validation”}

Sorry for bothering you. I’m completely new to this.

You have to select it with the Expression-Editor. After you changed it to an expression, (which you already did according to the color of the field) you should get it displayed automatically.
To access it now, you can simply click on it. Via the “menu” on the left side in the editor you should be able to navigate to the data and select the correct one.

Once you did that, you should see an expression like this:

{{$node["Mailchimp Trigger"].json["data[merges][EMAIL]"]}}

If it worked you should also see the correct data in the preview on the bottom and also if you close it in the node parameter.

Actually, If I go inside the Execution Error log the data is showing but can’t pick that in Expression editor.

I hope this makes clear bro.

If there is no data, then there is nothing that n8n can display. If you want to see data in the editor you have to run the workflow from the editor in test-mode. Here a short example video which does that:

If that does not help, I advise you to check out the n8n basic videos @svenjanssen did create. They should give you a good overview how n8n works:

Got it working man. Thank you so much.

Is there any option to donate? Happy to Donate soon. Will bookmark it now.